Sou a: Inici / Usuaris / q2dg / PAX (MP07) / UF2 / Xul.leta VLANs

Xul.leta VLANs

Plain Text icon XuletaVLANs.txt — Plain Text, 2 kB (2061 bytes)

Continguts del fitxer

---------------------PER CONFIGURAR VLANS----------------------

*Es crea la VLAN i s'assigna als ports desitjats dels switch

Switch(config)#vlan 6
Switch(config-vlan)#exit

Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 6
Switch(config-if)#exit

*Si és un enllaç "trunk" les comandes són aquestes:

Switch(config)#interface f0/5
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

*Es comprova que tot estigui bé:

Switch#show vlan
Switch#show vlan brief
Switch#show vlan id nº

*Per treure un port d'una VLAN:

Switch(config)#interface f0/1
Switch(config-if)#no switchport access vlan 6
Switch(config-if)#exit

*Per eliminar la VLAN:

Switch(config)#no vlan 6

---------------------PER ENRUTAR VLANS---------------------------

*Es creen les VLANs que el router haurà d'entendre:

Router(config)#vlan 6
Router(config-vlan)#exit
Router(config)#vlan 8
Router(config-vlan)#exit

*Es prepara la interfície real:

Router(config)#interface g0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
Router(config-if)#exit

*Es creen les interfícies virtuals associades a cada VLAN:

Router(config)#interface g0/0.6
Router(config-subif)#encapsulation dot1Q 6
Router(config-subif)#ip address 192.168.2.111 255.255.255.0
Router(config-subif)#exit
Router(config)#interface g0/0.8
Router(config-subif)#encapsulation dot1Q 8
Router(config-subif)#ip address 192.168.4.111 255.255.255.0
Router(config-subif)#exit

*Es comprova que tot estigui bé:

Router#show ip interface brief
Router#show ip route

*Òbviament, cada PC haurà de tenir com a porta d'enllaç la IP de la tarja del router pertanyent a la seva VLAN

---------------------ALTRES: SERVIDOR DHCP EN ROUTER-----------------------

service dhcp
ip dhcp pool un
network 192.168.2.0 255.255.255.0
default-router 192.168.2.111
exit
ip dhcp pool dos
network 192.168.4.0 255.255.255.0
default-router 192.168.4.111
exit

Els "pools" s'associen automàticament a la tarja de xarxa definida a "default-router"